Back to overview
Incident Report: Service Downtime Due to Google Cloud Outage
Jun 13 at 03:00am IST
Affected services
Display Ads API - APAC
Product Ads API - APAC
Product Ads API - US
Display Ads API - EUROPE
Product Ads API - Europe
Resolved
Jun 13 at 03:00am IST
Incident Summary:
On June 13th, 2025, between 12:00 AM IST and 2:00 AM IST, all dashboards and campaign management systems were unavailable due to a regional outage in Google Cloud services.
Impact:
- Users were unable to access core platform functionalities, including performance dashboards, campaign monitoring, and management tools.
- Campaign API calls and automated workflows dependent on Google Cloud infrastructure were intermittently failing during the outage window.
- Monitoring alerts were triggered across multiple services, confirming system-wide inaccessibility for user-facing modules.
Root Cause:
The outage was attributed to a service disruption within the Google Cloud Infrastructure (GCP), affecting our region's compute and storage components. This led to degraded availability of key microservices deployed on Google Kubernetes Engine (GKE), as well as access to Cloud SQL and BigQuery.
Resolution:
- Platform availability began recovering at 2:00 AM IST, once GCP services stabilized.
- Health checks and manual validations confirmed the restoration of all affected services.
Affected services
Display Ads API - APAC
Display Ads API - EUROPE
Product Ads API - APAC
Product Ads API - Europe
Product Ads API - US